ISDN Nailed-Up Sample Configuration Dynamic IP Routing |
Cisco ConfigMaker Windows 95/NT 4.0 configuration tool |
---|
This sample configuration dynamically routes IP between two IOS routers using the RIP routing protocol and PPP with CHAP authentication over ISDN. With RIP as the routing protocol, routing updates are constantly exchanged between the two routers. The periodic exchange of routing updates requires the ISDN line to be permanently active regardless of traffic demands. This is known as a nailed-up connection.
Though some cases might require a nailed up ISDN connection, most applications do not. Permanently active ISDN lines can result in potentially high ISDN costs and this configuration should only be used if ISDN billing is not a concern. Otherwise, it is highly recommended that a dial-on-demand routing (DDR) configuration is used. A DDR configuration activates the ISDN line only when there is traffic to send. DDR can be implemented either with a snapshot routing protocol to resolve routes dynamically or with static routes.
Get A DDR Configuration Using Snapshot Routing (recommended)
Faxback Doc #0511Get A DDR Configuration Using Static Routes
Faxback Doc #0511
Info On PPP Faxback Doc #ppp |
Info On
Snapshot Routing Faxback Doc #snapshot |
Info On IP
Unnumbered Faxback Doc #ip_unnum |
Before You Begin
Get
The IOS ISDN Command Glossary. Faxback Doc #0551 Detailed descriptions of all IOS commands used in ISDN configurations. Also provides links to the IOS Command Reference if more information is required |
Get The IOS Command Line Interface
Tutorial Faxback Doc #ios_tutorial Instructions on configuring an IOS router using the command line interface |
Preconfiguration Checklist |
---|
ISDN Information The following info must be gathered from the ISDN service provider
|
Network Information The following info must be gathered from the network administrator
|
Note: Commands followed by a <*> are on by default and do not have to be configured. The "!" marks that appear in the configuration are automatically entered by the router and function as line separators for easier reading.
Atlanta Router Configuration
In IOS "show running-config" format
version 11.2 <*>
service
udp-small-servers <*>
service
tcp-small-servers <*>
!
hostname Atlanta
!
enable secret cisco
!
username Boston password gocisco1
ip subnet-zero
no ip domain-lookup
isdn switch-type basic-ni1
!
interface Ethernet0
ip address 10.1.1.1 255.0.0.0
!
interface BRI0
no ip address <*>
encapsulation ppp
dialer rotary-group 0
isdn spid1 014045551111000 5551111
isdn spid2 014045552222000 5552222
no
fair-queue <*>
no cdp
enable <*>
!
interface Dialer0
ip unnumbered Ethernet0
encapsulation ppp
dialer in-band
dialer idle-timeout 300
dialer map ip 20.1.1.1 name Boston speed 56 broadcast
16175553333
dialer map ip 20.1.1.1 name Boston speed 56 broadcast
16175554444
dialer hold-queue 10
dialer load-threshold 200 either
dialer-group 1
no
fair-queue <*>
no cdp
enable <*>
ppp authentication chap
ppp multilink
!
router rip
version 2
network 10.0.0.0
no auto-summary
!
ip classless
ip http server
!
dialer-list 1 protocol ip permit
!
line
con 0
password console
login
line
aux 0 <*>
line vty 0 4
password telnet
login
<*>
!
end <*>
Boston Router Configuration
In IOS "show running-config" format
version 11.2 <*>
service
udp-small-servers <*>
service
tcp-small-servers <*>
!
hostname Boston
!
enable secret cisco
!
username Atlanta password gocisco1
ip subnet-zero
no ip domain-lookup
isdn switch-type basic-5ess
!
interface Ethernet0
ip address 20.1.1.1 255.0.0.0
!
interface BRI0
no ip address <*>
encapsulation ppp
dialer rotary-group 0
isdn spid1 0155533330 5553333
isdn spid2 0155533330 5554444
no
fair-queue <*>
no cdp
enable <*>
!
interface Dialer0
ip unnumbered Ethernet0
encapsulation ppp
dialer in-band
dialer idle-timeout 300
dialer map ip 10.1.1.1 name Atlanta speed 56 broadcast
14045551111
dialer map ip 10.1.1.1 name Atlanta speed 56 broadcast
14045552222
dialer hold-queue 10
dialer load-threshold 200 either
dialer-group 1
no
fair-queue <*>
no cdp
enable <*>
ppp authentication chap
ppp multilink
!
router rip
version 2
network 20.0.0.0
no auto-summary
!
ip classless
ip http server
!
dialer-list 1 protocol ip permit
!
line con
0
password console
login
line aux
0 <*>
line vty 0 4
password telnet
login
<*>
!
end <*>
After You've Tried
You've tried the configuration and it doesn't work. Help is available!
Get IOS Router ISDN Troubleshooting
Assistance Faxback Doc #isdn_ts |
All contents copyright © Cisco Systems, Inc. Important notices.