ISDN Dial-On-Demand Sample Configuration
Static IP Routing
Cisco ConfigMaker
Windows 95/NT 4.0 configuration tool

This sample configuration statically routes IP between two Cisco IOS routers using PPP with CHAP authentication over an IP unnumbered ISDN link. With static routes between the two routers, there is no need for the routers to exchange routing updates and the ISDN line activates only when traffic demands. This is known as dial-on-demand routing (DDR).

An alternative to DDR using static routes is DDR using a snapshot routing protocol. Snapshot routing allows routes to be automatically exchanged during a defined time interval instead of burdening a network administrator with the chore of manually maintaining static routes. Although the ISDN line must be activated to exchange snapshot routing updates, the duration and frequency of the snapshot interval can be configured such that any associated ISDN costs are relatively negligible compared with the benefits of simplified network administration.

DDR Dynamic IP Routing ConfigurationGet A DDR Configuration Using Snapshot Routing (recommended)
Faxback Doc #0511
PPP TutorialInfo On PPP
Faxback Doc #ppp
Snapshot Routing TutorialInfo On Snapshot Routing
Faxback Doc #snapshot
IP Unnumbered TutorialInfo On IP Unnumbered
Faxback Doc #ip_unnum
 

Before you begin

Detailed IOS Command DescriptionsGet The IOS ISDN Command Glossary.
Faxback Doc #0551
Detailed descriptions of all IOS commands used in ISDN configurations. Also provides links to the IOS Command Reference if more information is required
IOS Command Line TutorialGet The IOS Command Line Interface Tutorial
Faxback Doc #ios_tutorial
Instructions on configuring an IOS router using the command line interface
Preconfiguration Checklist
ISDN Information
The following info must be gathered from the ISDN service provider
  1. ISDN Switch Type
  2. ISDN SPIDs (where applicable)
    In North America, SPIDs are required for all ISDN switch types except for 5ESS Custom Point-to-point
  3. ISDN Directory Numbers
    The directory number is the local seven digit ISDN phone number (no area codes) of your router
Network Information
The following info must be gathered from the network administrator
  1. PPP Client Name
    A PPP client name must be assigned to both locations
  2. PPP Authentication Type
    CHAP authentication is preferred and used in this example
  3. PPP Password
    A PPP password must be assigned to both locations
  4. IP Address Information
    An IP network design must be created
  5. Phone Numbers
    ISDN phone numbers of both locations

Note: Commands followed by a <*> are on by default and do not have to be configured. The "!" marks that appear in the configuration are automatically entered by the router and function as line separators for easier reading.


Atlanta Router Configuration
In IOS "show running-config" format

version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Atlanta
!
enable secret cisco
!
username Boston password gocisco1
ip subnet-zero
no ip domain-lookup
isdn switch-type basic-ni1
!
interface Ethernet0
 ip address 10.1.1.1 255.0.0.0
!
interface BRI0
 no ip address <*>
 encapsulation ppp
 dialer rotary-group 0
 isdn spid1 014045551111000 5551111
 isdn spid2 014045552222000 5552222
 no fair-queue <*>
 no cdp enable <*>
!
interface Dialer0
 ip unnumbered Ethernet0
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 300
 dialer map ip 20.1.1.1 name Boston speed 56 16175553333
 dialer map ip 20.1.1.1 name Boston speed 56 16175554444
 dialer hold-queue 10
 dialer load-threshold 200 either
 dialer-group 1
 no fair-queue <*>
 no cdp enable <*>
 ppp authentication chap
 ppp multilink
!
ip classless
ip route 20.0.0.0 255.0.0.0 Dialer0
ip http server
!
dialer-list 1 protocol ip permit
!
line con 0
 password console
 login
line aux 0 <*>
line vty 0 4
 password telnet
 login <*>
!
end <*>


Boston Router Configuration
In IOS "show running-config" format

version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Boston
!
enable secret cisco
!
username Atlanta password gocisco1
ip subnet-zero
no ip domain-lookup
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 20.1.1.1 255.0.0.0
!
interface BRI0
 no ip address <*>
 encapsulation ppp
 dialer rotary-group 0
 isdn spid1 0155533330 5553333
 isdn spid2 0155533330 5554444
 no fair-queue <*>
 no cdp enable <*>
!
interface Dialer0
 ip unnumbered Ethernet0
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 300
 dialer map ip 10.1.1.1 name Atlanta speed 56 14045551111
 dialer map ip 10.1.1.1 name Atlanta speed 56 14045552222
 dialer hold-queue 10
 dialer load-threshold 200 either
 dialer-group 1
 no fair-queue <*>
 no cdp enable <*>
 ppp authentication chap
 ppp multilink
!
ip classless
ip route 10.0.0.0 255.0.0.0 Dialer0
ip http server
!
dialer-list 1 protocol ip permit
!
line con 0
 password console
 login
line aux 0 <*>
line vty 0 4
 password telnet
 login <*>
!
end <*>


After You've Tried

You've tried the configuration and it doesn't work. Help is available!

IOS Router ISDN Troubleshooting GuideGet IOS Router ISDN Troubleshooting Assistance
Faxback Doc #isdn_ts
 

All contents copyright © Cisco Systems, Inc. Important notices.