Hub And Spoke Frame Relay Sample Configuration
Static IPX Routing
Cisco ConfigMaker
Windows 95/NT 4.0 configuration tool

Note: The following configuration is for IPX only. It is a good idea to consider adding TCP/IP to the routers as well as IPX. Even though your network demands are strictly IPX, having TCP/IP on the routers will allow easier management and configuration through a remote telnet session.

Static IP And IPX Routing ConfigurationGet A Statically Routed IPX Configuration With IP Added For Easier Management
Faxback Doc #0523

This sample configuration statically routes IPX over a partially-meshed frame relay network using point-to-point subinterfaces. Static IPX routes and services must be manually created on every router for each desired destination. For smaller networks, static routing may suffice. However, for larger networks, manually maintaining static routing tables on every router can be an undesirable administrative chore.

Dynamic IPX Routing ConfigurationGet A Dynamically Routed IPX Configuration
Faxback Doc #0525
Dynamic IP And IPX Routing ConfigurationGet A Dynamically Routed IPX Configuration With IP Added For Easier Management (recommended)
Faxback Doc #0523

Subinterfaces logically divide a single, physical interface into separate, virtual point-to-point interfaces. A single frame relay interface connecting to multiple destinations can now be treated as a collection of point-to-point network segments. Each subinterface segment requires a unique IP subnet. Fortunately, unnumbered IP segments can be used to alleviate the burden of designing the additional IP subnets.

In general, it is good practice to use subinterfaces for partially-meshed frame relay networks. A frame relay network designed with subinterfaces scales much easier to future expansion. Referring to the example, subinterfaces allow routing updates to exchange between Boston and Chicago through Atlanta. Without subinterfaces, Boston is unable to receive routing updates from Chicago and vice versa creating a condition known as split-horizon. Even though IPX is statically routed in this example, it is a good idea to use subinterfaces for an easy, potential migration to dynamic routing at a future date.

Frame Relay Subinterface TutorialInfo On Subinterfaces
Faxback Doc #subifs
 

Before you begin

Detailed IOS Command DescriptionsGet The IOS Frame Relay Command Glossary.
Faxback Doc #0550
Detailed descriptions of all IOS commands used in frame relay configurations. Also provides links to the IOS Command Reference if more information is required
IOS Command Line TutorialGet The IOS Command Line Interface Tutorial
Faxback Doc #ios_tutorial
Instructions on configuring an IOS router using the command line interface
Preconfiguration Checklist
Frame Relay Information
The following info must be gathered from the frame relay provider
  1. Frame Relay LMI Type
    Common types include generic LMI (a.k.a. Cisco LMI) and ANSI Annex D

  2. DLCI Information
    The router requires a DLCI for every frame relay virtual circuit.

  3. DSU/CSU Information
    The circuit provider must provide clocking, data framing, and line encoding information to configure DSU/CSU successfully.
Network Information
The following info must be gathered from the network administrator
  1. IPX Address Information
    An IPX network design must be created. Each network segment requires a unique IPX network number.

Note: Commands followed by a <*> are on by default and do not have to be configured. The "!" marks that appear in the configuration are automatically entered by the router and function as line separators for easier reading.


Atlanta Router Configuration
In IOS "show running-config" format

version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Atlanta
!
enable secret cisco
!
ipx routing 0000.0caa.1111
!
interface Ethernet0
 no ip address <*>
 ipx network 100 encapsulation SAP
 ipx network 101 encapsulation NOVELL-ETHER secondary
!
interface Serial0
 no ip address <*>
 encapsulation frame-relay
 frame-relay lmi-type ansi
!
interface Serial0.16 point-to-point
 description Frame Relay to Boston
 ipx network AAAA
 ipx sap-interval 0
 frame-relay interface-dlci 16
!
interface Serial0.17 point-to-point
 description Frame Relay to Chicago
 ipx network BBBB
 ipx sap-interval 0
 frame-relay interface-dlci 17
!
ipx route 200 AAAA.0000.0cbb.2222
ipx route 300 BBBB.0000.0ccc.3333
ipx route 2000 AAAA.0000.0cbb.2222
ipx route 3000 BBBB.0000.0ccc.3333
!
ipx router rip
 no network AAAA
 no network BBBB
!
ipx sap 4 BostonFS 2000.0000.0000.0001 451 2
ipx sap 4 ChicagoFS 3000.0000.0000.0001 451 2
!
line con 0
 password console
 login
line aux 0 <*>
line vty 0 4
 login <*>
!
end <*>


Boston Router Configuration
In IOS "show running-config" format

version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Boston
!
enable secret cisco
!
ipx routing 0000.0cbb.2222
!
interface Ethernet0
 no ip address <*>
 ipx network 200
!
interface Serial0
 no ip address <*>
 encapsulation frame-relay
!
interface Serial0.16 point-to-point
 description Frame Relay to Atlanta
 ipx network AAAA
 ipx sap-interval 0
 frame-relay interface-dlci 16
!
ipx route 100 AAAA.0000.0caa.1111
ipx route 300 AAAA.0000.0caa.1111
ipx route 1000 AAAA.0000.0caa.1111
ipx route 3000 AAAA.0000.0caa.1111
!
ipx router rip
 no network AAAA
!
ipx sap 4 AtlantaFS 1000.0000.0000.0001 451 2
ipx sap 4 ChicagoFS 3000.0000.0000.0001 451 2
!
line con 0
 password console
 login
line aux 0 <*>
line vty 0 4
 login <*>
!
end <*>


Chicago Router Configuration
In IOS "show running-config" format

version 11.2 <*>
service udp-small-servers
<*>
service tcp-small-servers <*>
!
hostname Chicago
!
enable secret cisco
!
ipx routing 0000.0ccc.3333
!
interface Ethernet0
 no ip address <*>
 ipx network 300
!
interface Serial0
 no ip address <*>
 encapsulation frame-relay
 frame-relay lmi-type ansi
!
interface Serial0.16 point-to-point
 description Frame Relay to Atlanta
 ipx network BBBB
 ipx sap-interval 0
 frame-relay interface-dlci 16
!
ipx route 100 BBBB.0000.0caa.1111
ipx route 200 BBBB.0000.0caa.1111
ipx route 1000 BBBB.0000.0caa.1111
ipx route 2000 BBBB.0000.0caa.1111
!
ipx router rip
 no network BBBB
!
ipx sap 4 AtlantaFS 1000.0000.0000.0001 451 2
ipx sap 4 BostonFS 2000.0000.0000.0001 451 2
!
line con 0
 password console
 login
line aux 0 <*>
line vty 0 4
 login <*>
!
end <*>


After You've Tried

You've tried the configuration and it doesn't work. Help is available!

IOS Router Frame Relay Troubleshooting GuideGet IOS Router Frame Relay Troubleshooting Assistance
Faxback Doc #fr_ts
 

All contents copyright © Cisco Systems, Inc. Important notices.