Hub And Spoke Frame Relay Sample Configuration Dynamic IPX Routing |
Cisco ConfigMaker Windows 95/NT 4.0 configuration tool |
---|
Note: The following configuration is for IPX only. It is a good idea to consider adding TCP/IP to the routers as well as IPX. Even though your network demands are strictly IPX, having TCP/IP on the routers will allow easier management and configuration through a remote telnet session.
Get A Configuration With IP Added For Easier Management (recommended)
Faxback Doc #0523
This sample configuration routes IPX over a partially-meshed frame relay network using point-to-point subinterfaces. Routes and services are dynamically resolved using IPX RIP/SAP as the routing protocol.
Subinterfaces logically divide a single, physical interface into separate, virtual point-to-point interfaces. A single frame relay interface connecting to multiple destinations can now be treated as a collection of point-to-point network segments with each subinterface segment requiring a unique IPX network number.
In general, it is good practice to use subinterfaces for partially-meshed frame relay networks. A frame relay network designed with subinterfaces scales much easier to future expansion. Referring to the example, subinterfaces allow routing updates to exchange between Boston and Chicago through Atlanta. Without subinterfaces, Boston is unable to receive routing updates from Chicago and vice versa creating a condition known as split-horizon.
Info
On Subinterfaces Faxback Doc #subifs |
Get
The IOS Frame Relay Command Glossary. Faxback Doc #0550 Detailed descriptions of all IOS commands used in frame relay configurations. Also provides links to the IOS Command Reference if more information is required |
Get The IOS Command Line Interface
Tutorial Faxback Doc #ios_tutorial Instructions on configuring an IOS router using the command line interface |
Preconfiguration Checklist |
---|
Frame Relay Information The following info must be gathered from the frame relay provider
|
Network Information The following info must be gathered from the network administrator
|
Note: Commands followed by a <*> are on by default and do not have to be configured. The "!" marks that appear in the configuration are automatically entered by the router and function as line separators for easier reading.
Atlanta Router Configuration
In IOS "show running-config" format
version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Atlanta
!
enable secret cisco
!
ipx routing 0000.0caa.1111
!
interface Ethernet0
no ip address <*>
ipx network 100 encapsulation SAP
ipx network 101 encapsulation NOVELL-ETHER secondary
!
interface Serial0
no ip address <*>
encapsulation frame-relay
frame-relay lmi-type ansi
!
interface Serial0.16 point-to-point
description Frame Relay to Boston
ipx network AAAA
frame-relay interface-dlci 16 broadcast
!
interface Serial0.17 point-to-point
description Frame Relay to Chicago
ipx network BBBB
frame-relay interface-dlci 17 broadcast
!
line con 0
password console
login
line aux 0 <*>
line vty 0 4
login <*>
!
end <*>
Boston Router Configuration
In IOS "show running-config" format
version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Boston
!
enable secret cisco
!
ipx routing 0000.0cbb.2222
!
interface Ethernet0
no ip address <*>
ipx network 200
!
interface Serial0
no ip address <*>
encapsulation frame-relay
!
interface Serial0.16 point-to-point
description Frame Relay to Atlanta
ipx network AAAA
frame-relay interface-dlci 16 broadcast
!
line con 0
password console
login
line aux 0 <*>
line vty 0 4
login <*>
!
end <*>
Chicago Router Configuration
In IOS "show running-config" format
version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Chicago
!
enable secret cisco
!
ipx routing 0000.0ccc.3333
!
interface Ethernet0
no ip address <*>
ipx network 300
!
interface Serial0
no ip address <*>
encapsulation frame-relay
frame-relay lmi-type ansi
!
interface Serial0.16 point-to-point
description Frame Relay to Atlanta
ipx network BBBB
frame-relay interface-dlci 16 broadcast
!
line con 0
password console
login
line aux 0 <*>
line vty 0 4
login <*>
!
end <*>
After You've Tried
You've tried the configuration and it doesn't work. Help is available!
Get IOS Router Frame Relay
Troubleshooting Assistance Faxback Doc #fr_ts |
All contents copyright © Cisco Systems, Inc. Important notices.