Async Dial-On-Demand Sample Configuration
Dynamic IP And IPX Routing
Cisco ConfigMaker (requires Internet Access)
Windows 95/NT 4.0 configuration tool

This sample configuration dynamically routes both IP and IPX using snapshot routing and PPP with CHAP authentication over an asynchronous modem connected to the auxiliary port. With snapshot routing, IP route updates and IPX route and service updates are exchanged between routers during a user configured interval rather than the constant periodic exchange required of normal IP RIP and IPX RIP/SAP. Aside from this snapshot interval, the ISDN line activates only when traffic demands. This is known as dial-on-demand routing (DDR). In contrast, the periodic exchange of normal RIP would force the ISDN line to be permanently active, potentially resulting in high ISDN costs.

An alternative to DDR using a snapshot routing protocol is DDR using static routes. Routing tables are statically created by the network administrator eliminating the need for snapshot routing exchanges. For smaller networks, static routes may suffice. However, for larger networks, manually maintaining static routing tables on every router can be an administrative chore. Fortunately, the duration and frequency of the snapshot routing interval can be configured such that any ISDN costs due to dynamic routing are relatively negligible compared with the benefits of simplified network administration.

Static IP And IPX DDR ConfigurationGet A DDR Configuration Using Static Routes if static routing is still desired.
Faxback Doc #0557
PPP TutorialInfo On PPP
Faxback Doc #ppp
Snapshot Routing TutorialInfo On Snapshot Routing
Faxback Doc #snapshot
IP Unnumbered TutorialInfo On IP Unnumbered
Faxback Doc #ip_unnum
 

Before You Begin

Detailed IOS Command DescriptionsGet The IOS Async Command Glossary.
Faxback Doc #0552
Detailed descriptions of all IOS commands used in Async configurations. Also provides links to the IOS Command Reference if more information is required
IOS Command Line TutorialGet The IOS Command Line Interface Tutorial
Faxback Doc #ios_tutorial
Instructions on configuring an IOS router using the command line interface
Preconfiguration Checklist
Modem Information
The following info should be known about the telephone circuit
  1. Phone Numbers
    Verify phone numbers to be dialed along with any access code information (e.g. dialing a "9" to get an outside line etc.)
  2. Modem Settings
    Once the router is configured, 90% of async problems are modem related.
Network Information
The following info must be gathered from the network administrator
  1. PPP Client Name
    A PPP client name must be assigned to both locations
  2. PPP Authentication Type
    CHAP authentication is preferred and used in this example
  3. PPP Password
    A PPP password must be assigned to both locations
  4. IP Address Information
    An IP network design must be created
  5. IPX Address Information
    An IPX network design must be created

Note: Commands followed by a <*> are on by default and do not have to be configured. The "!" marks that appear in the configuration are automatically entered by the router and function as line separators for easier reading.


Atlanta Router Configuration
In IOS "show running-config" format

version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Atlanta
!
enable secret cisco
!
username Boston password gocisco1
ip subnet-zero
no ip domain-lookup
ipx routing 0000.0caa.1111
chat-script rstmdm "" "AT&FS0=1&B1&C1&D2&H1&K1&M4&R2" OK
chat-script dialnum ABORT ERROR ABORT BUSY "" "ATDT \T" TIMEOUT 60 CONNECT
!
interface Ethernet0
 ip address 10.1.1.1 255.0.0.0
 ipx network 100
!
interface Serial0
 no ip address <*>
 shutdown <*>
!
interface Async1
 no ip address <*>
 encapsulation ppp
 async default routing
 async mode dedicated
 dialer in-band
 dialer rotary-group 0
 no cdp enable <*>
!
interface Dialer0
 ip unnumbered Ethernet0
 ip tcp header-compression passive
 encapsulation ppp
 ipx network AAAA
 dialer in-band
 dialer map snapshot 1 name Boston 16175553333
 dialer map ipx AAAA.0000.0cbb.2222 name Boston broadcast 16175553333
 dialer map ip 20.1.1.1 name Boston broadcast 16175553333
 dialer-group 1
 snapshot server 5 dialer
 no cdp enable <*>
 ppp authentication chap
!
router rip
 version 2
 network 10.0.0.0
 no auto-summary
!
ip classless
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
!
line con 0
 password console
 login
line aux 0
 script dialer dialnum
 script reset rstmdm
 modem InOut
 transport input all
 rxspeed 38400
 txspeed 38400
 stopbits 1
 flowcontrol hardware
line vty 0 4
 password telnet
 login
!
end <*>


Boston Router Configuration
In IOS "show running-config" format

version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Boston
!
enable secret cisco
!
username Atlanta password gocisco1
ip subnet-zero
no ip domain-lookup
ipx routing 0000.0cbb.2222
chat-script rstmdm "" "AT&FS0=1&B1&C1&D2&H1&K1&M4&R2" OK
chat-script dialnum ABORT ERROR ABORT BUSY "" "ATDT \T" TIMEOUT 60 CONNECT
!
interface Ethernet0
 ip address 20.1.1.1 255.0.0.0
 ipx network 200
!
interface Serial0
 no ip address <*>
 shutdown <*>
!
interface Async1
 no ip address <*>
 encapsulation ppp
 async default routing
 async mode dedicated
 dialer in-band
 dialer rotary-group 0
 no cdp enable <*>
!
interface Dialer0
 ip unnumbered Ethernet0
 encapsulation ppp
 ipx network AAAA
 dialer in-band
 dialer map snapshot 1 name Atlanta 14045551111
 dialer map ip 10.1.1.1 name Atlanta broadcast 14045551111
 dialer map ipx AAAA.0000.0caa.1111 name Atlanta broadcast 14045551111
 dialer-group 1
 snapshot client 5 360 dialer
 no cdp enable <*>
 ppp authentication chap
!
router rip
 version 2
 network 20.0.0.0
 no auto-summary
!
ip classless
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
!
line con 0
 password console
 login
line aux 0
 script dialer dialnum
 script reset rstmdm
 modem InOut
 transport input all
 rxspeed 38400
 txspeed 38400
 stopbits 1
 flowcontrol hardware
 line vty 0 4
 password telnet
 login
!
end <*>


After You've Tried

You've tried the configuration and it doesn't work. Help is available!

IOS Router ISDN Troubleshooting GuideGet IOS Router Async Troubleshooting Assistance
Faxback Doc #async_ts
 

All contents copyright © Cisco Systems, Inc. Important notices.