Async Dial-On-Demand Sample Configuration
Static IP, IPX, And AppleTalk Routing
Cisco ConfigMaker (requires Internet Access)
Windows 95/NT 4.0 configuration tool

This sample configuration statically routes IP, IPX and AppleTalk using PPP with CHAP authentication over an asynchronous modem connected to the auxiliary port. With static routes between the two routers, there is no need for the routers to exchange routing updates and the phone line activates only when traffic demands. This is known as dial-on-demand routing (DDR).

An alternative to DDR using static routes is DDR using a snapshot routing protocol. Snapshot routing allows routes to be automatically exchanged during a defined time interval instead of burdening a network administrator with the chore of manually maintaining static routes. Although the phone line must be activated for each snapshot routing update, the duration and frequency of the snapshot interval can be configured such that any phone costs due to dynamic routing are relatively negligible compared with the benefits of simplified network administration.

Dynamic IP, IPX And AT DDR ConfigurationGet A Configuration Using Snapshot Routing (recommended)
Faxback Doc #0559
PPP TutorialInfo On PPP
Faxback Doc #ppp
Snapshot Routing TutorialInfo On Snapshot Routing
Faxback Doc #snapshot
IP Unnumbered TutorialInfo On IP Unnumbered
Faxback Doc #ip_unnum
 

Before You Begin

Detailed IOS Command DescriptionsGet The IOS Async Command Glossary.
Faxback Doc #0552
Detailed descriptions of all IOS commands used in Async configurations. Also provides links to the IOS Command Reference if more information is required
IOS Command Line TutorialGet The IOS Command Line Interface Tutorial
Faxback Doc #ios_tutorial
Instructions on configuring an IOS router using the command line interface
Preconfiguration Checklist
Modem Information
The following info should be known about the telephone circuit
  1. Phone Numbers
    Verify phone numbers to be dialed along with any access code information (e.g. dialing a "9" to get an outside line etc.)
  2. Modem Settings
    Once the router is configured, 90% of async problems are modem related.
Network Information
The following info must be gathered from the network administrator
  1. PPP Client Name
    A PPP client name must be assigned to both locations
  2. PPP Authentication Type
    CHAP authentication is preferred and used in this example
  3. PPP Password
    A PPP password must be assigned to both locations
  4. IP Address Information
    An IP network design must be created
  5. IPX Address Information
    An IPX network design must be created
  6. AppleTalk Address Information
    An AppleTalk network design must be created

Note: Commands followed by a <*> are on by default and do not have to be configured. The "!" marks that appear in the configuration are automatically entered by the router and function as line separators for easier reading.


Atlanta Router Configuration
In IOS "show running-config" format

version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Atlanta
!
enable secret cisco
!
username Boston password gocisco1
ip subnet-zero
no ip domain-lookup
appletalk routing
ipx routing 0000.0caa.1111
chat-script dialnum ABORT ERROR ABORT BUSY "" "ATDT \T" TIMEOUT 60 CONNECT
chat-script rstmdm "" "AT&FS0=1&B1&C1&D2&H1&K1&M4&R2" OK
!
interface Ethernet0
 ip address 10.1.1.1 255.0.0.0
 appletalk cable-range 100-199 100.1
 appletalk zone Atlanta
 ipx network 100
!
interface Serial0
 no ip address <*>
 shutdown <*>
!
interface Async1
 no ip address <*>
 encapsulation ppp
 async default routing
 async mode dedicated
 dialer in-band
 dialer rotary-group 0
 no cdp enable <*>
!
interface Dialer0
 ip unnumbered Ethernet0
 ip tcp header-compression passive
 encapsulation ppp
 appletalk cable-range 900-999 900.1
 appletalk zone WAN
 no appletalk send-rtmps
 ipx network AAAA
 dialer in-band
 dialer map appletalk 900.2 name Boston 16175553333
 dialer map ip 20.1.1.1 name Boston 16175553333
 dialer map ipx AAAA.0000.0cbb.2222 name Boston 16175553333
 dialer-group 1
 no cdp enable <*>
 ppp authentication chap
!
ip classless
ip route 20.0.0.0 255.0.0.0 20.1.1.1
ip route 20.1.1.1 255.255.255.255 Dialer0
appletalk static cable-range 200-299 to 900.2 zone Boston
!
ipx route 2000 AAAA.0000.0cbb.2222
ipx route 200 AAAA.0000.0cbb.2222
!
ipx sap 4 BostonFS 2000.0000.0000.0001 451 2
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
dialer-list 1 protocol appletalk permit
!
line con 0
 password console
 login
line aux 0
 script dialer dialnum
 script reset rstmdm
 modem InOut
 transport input all
 stopbits 1
 rxspeed 38400
 txspeed 38400
 flowcontrol hardware
line vty 0 4
 password telnet
 login
!
end <*>


Boston Router Configuration
In IOS "show running-config" format

version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Boston
!
enable secret cisco
!
username Atlanta password gocisco1
ip subnet-zero
no ip domain-lookup
appletalk routing
ipx routing 0000.0cbb.2222
chat-script rstmdm "" "AT&FS0=1&B1&C1&D2&H1&K1&M4&R2" OK
chat-script dialnum ABORT ERROR ABORT BUSY "" "ATDT \T" TIMEOUT 60 CONNECT
!
interface Ethernet0
 ip address 20.1.1.1 255.0.0.0
 appletalk cable-range 200-299 200.1
 appletalk zone Boston
 ipx network 200
!
interface Serial0
 no ip address <*>
 shutdown <*>
!
interface Async1
 no ip address <*>
 encapsulation ppp
 async default routing
 async mode dedicated
 dialer in-band
 dialer rotary-group 0
 no cdp enable <*>
!
interface Dialer0
 ip unnumbered Ethernet0
 encapsulation ppp
 appletalk cable-range 900-999 900.2
 appletalk zone WAN
 no appletalk send-rtmps
 ipx network AAAA
 dialer in-band
 dialer map appletalk 900.1 name Atlanta 14045551111
 dialer map ip 10.1.1.1 name Atlanta 14045551111
 dialer map ipx AAAA.0000.0caa.1111 name Atlanta 14045551111
 dialer-group 1
 no cdp enable <*>
 ppp authentication chap
!
ip classless
ip route 10.1.1.1 255.255.255.255 Dialer0
ip route 10.0.0.0 255.0.0.0 10.1.1.1
appletalk static cable-range 100-199 to 900.1 zone Atlanta
!
ipx route 1000 AAAA.0000.0caa.1111
ipx route 100 AAAA.0000.0caa.1111
!
ipx sap 4 AtlantaFS 1000.0000.0000.0001 451 2
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
dialer-list 1 protocol appletalk permit
!
line con 0
 password console
 login
line aux 0
 script dialer dialnum
 script reset rstmdm
 modem InOut
 transport input all
 stopbits 1
 rxspeed 38400
 txspeed 38400
 flowcontrol hardware
line vty 0 4
 password telnet
 login
!
end <*>


After You've Tried

You've tried the configuration and it doesn't work. Help is available!

IOS Router ISDN Troubleshooting GuideGet IOS Router Async Troubleshooting Assistance
Faxback Doc #async_ts
 

All contents copyright © Cisco Systems, Inc. Important notices.