ISDN Dial-On-Demand Sample Configuration
Connecting A Private Network To An ISP Using CHAP Authentication
Get Cisco ConfigMakerCisco ConfigMaker
Windows 95/NT 4.0 configuration tool

This sample configuration connects a private IP network to an Internet Service Provider (ISP) using PPP with CHAP authentication over ISDN. The ISDN line activates only when needed. This is known as dial-on-demand routing (DDR).

Using a private IP network on the LAN in conjunction with the Network Address Translation (NAT) feature reduces the expense of purchasing registered IP addresses. Network Address Translation (NAT) allows the router to forward packets between a private IP network and the Internet. If access to a network appliance (e.g. Web Server) residing on the private network is desired, a static Network Address Translation can be configured to allow access to incoming Internet users.

Note: Network Address Translation is configured only on the NAT border router (i.e. Atlanta).

ISP NAT Configuration With PAPGet A NAT Configuration Using PAP Authentication if the ISP uses PAP instead of CHAP
Faxback Doc #isdn_isp_pap_nat
PPP TutorialInfo On PPP
Faxback Doc #ppp
NAT TutorialInfo On NAT
Faxback Doc #nat
IP Unnumbered TutorialInfo On IP Unnumbered
Faxback Doc #ip_unnum
 

Before You Begin

Detailed IOS Command DescriptionsGet The IOS ISDN Command Glossary.
Faxback Doc #0551
Detailed descriptions of all IOS commands used in ISDN configurations. Also provides links to the IOS Command Reference if more information is required
IOS Command Line TutorialGet The IOS Command Line Interface Tutorial
Faxback Doc #ios_tutorial
Instructions on configuring an IOS router using the command line interface
Preconfiguration Checklist
ISDN Information
The following info must be gathered from the ISDN service provider
  1. ISDN Switch Type
  2. ISDN SPIDs (where applicable)
    In North America, SPIDs are required for all ISDN switch types except for 5ESS Custom Point-to-point
  3. ISDN Directory Numbers
    The directory number is the local seven digit ISDN phone number (no area codes) of your router
ISP Information
The following info must be gathered from the ISP
  1. PPP Client Name
    The ISP assigns this name as your login name
  2. PPP Authentication Type
    PAP or CHAP PPP authentication
  3. PPP Password
    The password the ISP will expect you to supply when you login
  4. IP Address Information
    The IP addresses and subnet mask to be used in the router's public address pool.
  5. ISP Phone Number
    ISDN phone number of the ISP

Note: Commands followed by a <*> are on by default and do not have to be configured. The "!" marks that appear in the configuration are automatically entered by the router and function as line separators for easier reading.


Atlanta Router Configuration
In IOS "show running-config" format

version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Atlanta
!
enable secret cisco
!
ip subnet-zero
ip nat translation timeout 1800
ip nat inside source list 1 interface dialer 0 overload
ip nat inside source static 10.1.1.3 215.1.1.2
no ip domain-lookup
isdn switch-type basic-ni1
!
interface Ethernet0
 ip address 10.1.1.1 255.0.0.0
 ip nat inside
!
interface BRI0
 no ip address <*>
 ip nat outside
 encapsulation ppp
 dialer rotary-group 0
 isdn spid1 014045551111000 5551111
 isdn spid2 014045552222000 5552222
 no fair-queue <*>
 no cdp enable <*>
!
interface Dialer0
 ip address 215.1.1.1 255.255.255.0
 ip nat outside
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 300
 dialer string 14085553333 class 56K
 dialer hold-queue 10
 dialer load-threshold 200 either
 dialer-group 1
 no fair-queue <*>
 no cdp enable <*>
 ppp authentication chap callin
 ppp chap hostname Atlanta
 ppp chap password gocisco1
 ppp multilink
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 20.0.0.0 255.0.0.0 10.1.1.2
ip http server
!
map-class dialer 56K
 dialer isdn speed 56
access-list 1 permit 10.0.0.0 0.255.255.255
access-list 1 permit 20.0.0.0 0.255.255.255
dialer-list 1 protocol ip permit
!
 line con 0
 password console
 login
 line aux 0 <*>
line vty 0 4
 password telnet
 login <*>
!
end <*>


Boston Router Configuration
In IOS "show running-config" format

version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Boston
!
enable secret cisco
!
ip subnet-zero
no ip domain-lookup
!
interface Ethernet0
 ip address 20.1.1.1 255.0.0.0
!
interface Ethernet1
 ip address 10.1.1.2 255.0.0.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.1.1.1
ip http server
!
 line con 0
 password console
 login
 line aux 0 <*>
line vty 0 4
 password telnet
 login <*>
!
end <*>


After You've Tried

You've tried the configuration and it doesn't work. Help is available!

IOS Router ISDN Troubleshooting GuideGet IOS Router ISDN Troubleshooting Assistance
Faxback Doc #isdn_ts
 

All contents copyright © Cisco Systems, Inc. Important notices.