ISDN Dial-On-Demand Sample Configuration Dynamic IP And IPX Routing |
Cisco ConfigMaker Windows 95/NT 4.0 configuration tool |
---|
This sample configuration dynamically routes both IP and IPX between two Cisco IOS routers using snapshot IP RIP, snapshot IPX RIP/SAP, and PPP with CHAP authentication over an ISDN link. With snapshot routing, IP route updates and IPX route and service updates are exchanged between routers during a user configured interval rather than the constant periodic exchange required of normal IP RIP and IPX RIP/SAP. Aside from this snapshot interval, the ISDN line activates only when traffic demands. This is known as dial-on-demand routing (DDR). In contrast, the periodic exchange of normal RIP would force the ISDN line to be permanently active, potentially resulting in high ISDN costs.
An alternative to DDR using a snapshot routing protocol is DDR using static routes. Routing tables are statically created by the network administrator eliminating the need for snapshot routing exchanges. For smaller networks, static routes may suffice. However, for larger networks, manually maintaining static routing tables on every router can be an administrative chore. Fortunately, the duration and frequency of the snapshot routing interval can be configured such that any ISDN costs due to dynamic routing are relatively negligible compared with the benefits of simplified network administration.
Get A DDR Configuration Using Static Routes if static routing is still desired.
Faxback Doc #0514
Info On PPP Faxback Doc #ppp |
Info On
Snapshot Routing Faxback Doc #snapshot |
Info On IP
Unnumbered Faxback Doc #ip_unnum |
Before You Begin
Get
The IOS ISDN Command Glossary. Faxback Doc #0551 Detailed descriptions of all IOS commands used in ISDN configurations. Also provides links to the IOS Command Reference if more information is required |
Get The IOS Command Line Interface
Tutorial Faxback Doc #ios_tutorial Instructions on configuring an IOS router using the command line interface |
Preconfiguration Checklist |
---|
ISDN Information The following info must be gathered from the ISDN service provider
|
Network Information The following info must be gathered from the network administrator
|
Note: Commands followed by a <*> are on by default and do not have to be configured. The "!" marks that appear in the configuration are automatically entered by the router and function as line separators for easier reading.
Atlanta Router Configuration
In IOS "show running-config" format
version 11.2 <*>
service
udp-small-servers <*>
service
tcp-small-servers <*>
!
hostname Atlanta
!
enable secret cisco
!
username Boston password gocisco1
ip subnet-zero
no ip domain-lookup
ipx routing 0000.0caa.1111
isdn switch-type basic-ni1
!
interface Ethernet0
ip address 10.1.1.1 255.0.0.0
ipx network 100 encapsulation SAP
ipx network 101 encapsulation NOVELL-ETHER
secondary
!
interface BRI0
no ip address <*>
encapsulation ppp
dialer rotary-group 0
isdn spid1 014045551111000 5551111
isdn spid2 014045552222000 5552222
no
fair-queue <*>
no cdp
enable <*>
!
interface Dialer0
ip unnumbered Ethernet0
encapsulation ppp
ipx network AAAA
no ipx route-cache
ipx watchdog-spoof
dialer in-band
dialer idle-timeout 300
dialer map snapshot 1 name Boston speed 56
dialer map ipx AAAA.0000.0cbb.2222 name Boston
speed 56 broadcast 16175553333
dialer map ipx AAAA.0000.0cbb.2222 name Boston
speed 56 broadcast 16175554444
dialer map ip 20.1.1.1 name Boston speed 56
broadcast 16175553333
dialer map ip 20.1.1.1 name Boston speed 56
broadcast 16175554444
dialer hold-queue 10
dialer load-threshold 200 either
dialer-group 1
snapshot server 15
no
fair-queue <*>
no cdp
enable <*>
ppp authentication chap
ppp multilink
!
router rip
version 2
network 10.0.0.0
no auto-summary
!
ip classless
ip http server
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
!
line con
0
password console
login
line
aux 0 <*>
line vty 0 4
password telnet
login <*>
!
end <*>
Boston Router Configuration
In IOS "show running-config" format
version 11.2 <*>
service
udp-small-servers <*>
service
tcp-small-servers <*>
!
hostname Boston
!
enable secret cisco
!
username Atlanta password gocisco1
ip subnet-zero
no ip domain-lookup
ipx routing 0000.0cbb.2222
isdn switch-type basic-5ess
!
interface Ethernet0
ip address 20.1.1.1 255.0.0.0
ipx network 200
!
interface BRI0
no ip address <*>
encapsulation ppp
dialer rotary-group 0
isdn spid1 0155533330 5553333
isdn spid2 0155533330 5554444
no
fair-queue <*>
no cdp
enable <*>
!
interface Dialer0
ip unnumbered Ethernet0
encapsulation ppp
ipx network AAAA
no ipx route-cache
ipx watchdog-spoof
dialer in-band
dialer idle-timeout 300
dialer map snapshot 1 name Atlanta speed 56
14045551111
dialer map ipx AAAA.0000.0caa.1111 name
Atlanta speed 56 broadcast 14045551111
dialer map ipx AAAA.0000.0caa.1111 name
Atlanta speed 56 broadcast 14045552222
dialer map ip 10.1.1.1 name Atlanta speed
56 broadcast 14045551111
dialer map ip 10.1.1.1 name Atlanta speed
56 broadcast 14045552222
dialer hold-queue 10
dialer load-threshold 200 either
dialer-group 1
snapshot client 15 600
suppress-statechange-update dialer
no
fair-queue <*>
no cdp
enable <*>
ppp authentication chap
ppp multilink
!
router rip
version 2
network 20.0.0.0
no auto-summary
!
ip classless
ip http server
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
!
line con
0
password console
login
line
aux 0 <*>
line vty 0 4
password telnet
login <*>
!
end <*>
After You've Tried
You've tried the configuration and it doesn't work. Help is available!
Get IOS Router ISDN Troubleshooting
Assistance Faxback Doc #isdn_ts |
All contents copyright © Cisco Systems, Inc. Important notices.