Hub And Spoke Frame Relay Sample Configuration
IPX Routing, Bridging All Other Protocols
Cisco ConfigMaker
Windows 95/NT 4.0 configuration tool

Note: The following configuration is for IPX only. It is a good idea to consider adding TCP/IP to the routers as well as IPX. Even though your network demands are strictly IPX, having TCP/IP on the routers will allow easier management and configuration through a remote telnet session.

This sample configuration routes IPX and bridges all other protocols over a partially-meshed frame relay network using point-to-point subinterfaces. IPX routes and services are dynamically resolved using IPX RIP/SAP as the routing protocol. The IP addresses included in this example are not necessary, but added for remote access via a telnet session. Notice that the routers are on the same IP network number because IP is bridged.

Subinterfaces logically divide a single, physical interface into separate, virtual point-to-point interfaces. A single frame relay interface connecting to multiple destinations can now be treated as a collection of point-to-point network segments. Each subinterface segment requires a unique IP subnet and IPX network number. Fortunately, unnumbered IP segments can be used to alleviate the burden of designing the additional IP subnets.

In general, it is good practice to use subinterfaces for partially-meshed frame relay networks. A frame relay network designed with subinterfaces scales much easier to future expansion. Referring to the example, subinterfaces allow routing updates to exchange between Boston and Chicago through Atlanta. Without subinterfaces, Boston is unable to receive routing updates from Chicago and vice versa creating a condition known as split-horizon.

Frame Relay Subinterface TutorialInfo On Subinterfaces
Faxback Doc #subifs

Before You Begin

Detailed IOS Command DescriptionsGet The IOS Frame Relay Command Glossary.
Faxback Doc #0550
Detailed descriptions of all IOS commands used in frame relay configurations. Also provides links to the IOS Command Reference if more information is required
IOS Command Line TutorialGet The IOS Command Line Interface Tutorial
Faxback Doc #ios_tutorial
Instructions on configuring an IOS router using the command line interface
Preconfiguration Checklist
Frame Relay Information
The following info must be gathered from the frame relay provider
  1. Frame Relay LMI Type
    Common types include generic LMI (a.k.a. Cisco LMI) and ANSI Annex D

  2. DLCI Information
    The router requires a DLCI for every frame relay virtual circuit.

  3. DSU/CSU Information
    The circuit provider must provide clocking, data framing, and line encoding information to configure DSU/CSU successfully.
Network Information
The following info must be gathered from the network administrator
  1. IP Address Information
    If remote management of the routers through a telnet session is desired, an IP network design must be created.

  2. IPX Address Information
    An IPX network design must be created. Each network segment requires a unique IPX network number.

Note: Commands followed by a <*> are on by default and do not have to be configured. The "!" marks that appear in the configuration are automatically entered by the router and function as line separators for easier reading.


Atlanta Router Configuration
In IOS "show running-config" format

version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Atlanta
!
enable secret cisco
!
ip subnet-zero
no ip routing
no ip domain-lookup
ipx routing 0000.0caa.1111
!
interface Ethernet0
 ip address 10.1.1.1 255.0.0.0
 ipx network 100 encapsulation SAP
 ipx network 101 encapsulation NOVELL-ETHER secondary
 bridge-group 1
!
interface Serial0
 no ip address <*>
 encapsulation frame-relay
 frame-relay lmi-type ansi
!
interface Serial0.16 point-to-point
 description Frame Relay to Boston
 ip address 10.1.1.1 255.0.0.0
 ipx network AAAA
 frame-relay interface-dlci 16 broadcast
 bridge-group 1
!
interface Serial0.17 point-to-point
 description Frame Relay to Chicago
 ip address 10.1.1.1 255.0.0.0
 ipx network BBBB
 frame-relay interface-dlci 17 broadcast
 bridge-group 1
!
ip http server
!
bridge 1 protocol ieee
!
line con 0
 password console
 login
line aux 0 <*>
line vty 0 4
 password telnet
 login <*>
!
end <*>


Boston Router Configuration
In IOS "show running-config" format

version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Boston
!
enable secret cisco
!
ip subnet-zero
no ip routing
no ip domain-lookup
ipx routing 0000.0cbb.2222
!
interface Ethernet0
 ip address 10.2.2.2 255.0.0.0
 ipx network 200
 bridge-group 1
!
interface Serial0
 no ip address <*>
 encapsulation frame-relay
!
interface Serial0.16 point-to-point
 description Frame Relay to Atlanta
 ip address 10.2.2.2 255.0.0.0
 ipx network AAAA
 frame-relay interface-dlci 16 broadcast
 bridge-group 1
!
ip http server
!
bridge 1 protocol ieee
!
line con 0
 password console
 login
line aux 0 <*>
line vty 0 4
 password telnet
 login <*>
!
end <*>


Chicago Router Configuration
In IOS "show running-config" format

version 11.2 <*>
service udp-small-servers
<*>
service tcp-small-servers <*>
!
hostname Chicago
!
enable secret cisco
!
ip subnet-zero
no ip routing
no ip domain-lookup
ipx routing 0000.0ccc.3333
!
interface Ethernet0
 ip address 10.3.3.3 255.0.0.0
 ipx network 300
 bridge-group 1
!
interface Serial0
 no ip address <*>
 encapsulation frame-relay
 frame-relay lmi-type ansi
!
interface Serial0.16 point-to-point
 description Frame Relay to Atlanta
 ip address 10.3.3.3 255.0.0.0
 ipx network BBBB
 frame-relay interface-dlci 16 broadcast
 bridge-group 1
!
ip http server
!
bridge 1 protocol ieee
!
line con 0
 password console
 login
line aux 0 <*>
line vty 0 4
 password telnet
 login <*>
!
end <*>


After You've Tried

You've tried the configuration and it doesn't work. Help is available!

IOS Router Frame Relay Troubleshooting GuideGet IOS Router Frame Relay Troubleshooting Assistance
Faxback Doc #fr_ts
 

All contents copyright © Cisco Systems, Inc. Important notices.