Hub And Spoke Frame Relay Sample Configuration
Dynamic (OSPF) IP Routing
Cisco ConfigMaker
Windows 95/NT 4.0 configuration tool

This sample configuration routes TCP/IP over a partially-meshed frame relay network using point-to-point subinterfaces. IP routes are dynamically resolved using Open Shortest Path First (OSPF) as the routing protocol. Special care is needed when configuring OSPF over partially-meshed frame relay. OSPF requires direct connections to each neighbor in order to elect a Designated Router (DR) and form adjacencies with neighboring OSPF routers. However, the physical topology of a partially-meshed frame relay network does not provide the direct access that OSPF requires.

The solution to the adjacency problem is to use subinterfaces. Subinterfaces logically divide a single, physical interface into separate, virtual point-to-point interfaces. A single frame relay interface connecting to multiple destinations can now be treated as a collection of point-to-point network segments. The point-to-point connections allow routers to form OSPF adjacencies without DR election. Although each subinterface segment requires a unique IP subnet, unnumbered IP segments can be used to alleviate the burden of designing the additional IP subnets.

In general, it is good practice to use subinterfaces for partially-meshed frame relay networks. A frame relay network designed with subinterfaces scales much easier to future expansion. Referring to the example, subinterfaces allow routing updates to exchange between Boston and Chicago through Atlanta. Without subinterfaces, Boston is unable to receive routing updates from Chicago and vice versa creating a condition known as split-horizon.

OSPF Design GuideOSPF Design Guide
Faxback Doc #ospf
Frame Relay Subinterface TutorialInfo On Subinterfaces
Faxback Doc #subifs
IP Unnumbered TutorialInfo On IP Unnumbered
Faxback Doc #ip_unnum
 

Before you begin

Detailed IOS Command DescriptionsGet The IOS Frame Relay Command Glossary.
Faxback Doc #0550
Detailed descriptions of all IOS commands used in frame relay configurations. Also provides links to the IOS Command Reference if more information is required
IOS Command Line TutorialGet The IOS Command Line Interface Tutorial
Faxback Doc #ios_tutorial
Instructions on configuring an IOS router using the command line interface
Preconfiguration Checklist
Frame Relay Information
The following info must be gathered from the frame relay provider
  1. Frame Relay LMI Type
    Common types include generic LMI (a.k.a. Cisco LMI) and ANSI Annex D

  2. DLCI Information
    The router requires a DLCI for every frame relay virtual circuit.

  3. DSU/CSU Information
    The circuit provider must provide clocking, data framing, and line encoding information to configure DSU/CSU successfully.
Network Information
The following info must be gathered from the network administrator
  1. IP Address Information
    An IP network design must be created. Separate IP network subnets are required at each site.

Note: Commands followed by a <*> are on by default and do not have to be configured. The "!" marks that appear in the configuration are automatically entered by the router and function as line separators for easier reading.


Atlanta Router Configuration
In IOS "show running-config" format

version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Atlanta
!
enable secret cisco
!
ip subnet-zero
no ip domain-lookup
!
interface Ethernet0
 ip address 10.1.1.1 255.0.0.0
!
interface Serial0
 no ip address <*>
 encapsulation frame-relay
 frame-relay lmi-type ansi
!
interface Serial0.16 point-to-point
 description Frame Relay to Boston
 ip unnumbered Ethernet0
 frame-relay interface-dlci 16 broadcast
!
interface Serial0.17 point-to-point
 description Frame Relay to Chicago
 ip unnumbered Ethernet0
 frame-relay interface-dlci 17 broadcast
!
router ospf 1
 network 10.0.0.0 0.255.255.255 area 0
!
ip http server
ip classless
!
line con 0
 password console
 login
line aux 0 <*>
line vty 0 4
 password telnet
 login <*>
!
end <*>


Boston Router Configuration
In IOS "show running-config" format

version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Boston
!
enable secret cisco
!
ip subnet-zero
no ip domain-lookup
!
interface Ethernet0
 ip address 20.1.1.1 255.0.0.0
!
interface Serial0
 no ip address <*>
 encapsulation frame-relay
!
interface Serial0.16 point-to-point
 description Frame Relay to Atlanta
 ip unnumbered Ethernet0
 frame-relay interface-dlci 16 broadcast
!
router ospf 2
 network 20.0.0.0 0.255.255.255 area 0
!
ip http server
ip classless
!
line con 0
 password console
 login
line aux 0 <*>
line vty 0 4
 password telnet
 login <*>
!
end <*>


Chicago Router Configuration
In IOS "show running-config" format

version 11.2 <*>
service udp-small-servers
<*>
service tcp-small-servers <*>
!
hostname Chicago
!
enable secret cisco
!
ip subnet-zero
no ip domain-lookup
!
interface Ethernet0
 ip address 30.1.1.1 255.0.0.0
!
interface Serial0
 no ip address <*>
 encapsulation frame-relay
 frame-relay lmi-type ansi
!
interface Serial0.16 point-to-point
 description Frame Relay to Atlanta
 ip unnumbered Ethernet0
 frame-relay interface-dlci 16 broadcast
!
router ospf 3
 network 30.0.0.0 0.255.255.255 area 0
!
ip http server
ip classless
!
line con 0
 password console
 login
line aux 0 <*>
line vty 0 4
 password telnet
 login <*>
!
end <*>


After You've Tried

You've tried the configuration and it doesn't work. Help is available!

IOS Router Frame Relay Troubleshooting GuideGet IOS Router Frame Relay Troubleshooting Assistance
Faxback Doc #fr_ts
 

All contents copyright © Cisco Systems, Inc. Important notices.