Hub And Spoke Frame Relay Sample Configuration Dynamic IP Routing |
Cisco ConfigMaker Windows 95/NT 4.0 configuration tool |
---|
This sample configuration dynamically routes IP over a partially-meshed frame relay network using point-to-point subinterfaces and RIP version 2 as the routing protocol.
Subinterfaces logically divide a single, physical interface into separate, virtual point-to-point interfaces. A single frame relay interface connecting to multiple destinations can now be treated as a collection of point-to-point network segments. Each subinterface segment requires a unique IP subnet. Fortunately, unnumbered IP segments can be used to alleviate the burden of designing the additional IP subnets.
In general, it is good practice to use subinterfaces for partially-meshed frame relay networks. A frame relay network designed with subinterfaces scales much easier to future expansion. Referring to the example, subinterfaces allow routing updates to exchange between Boston and Chicago through Atlanta. Without subinterfaces, Boston is unable to receive routing updates from Chicago and vice versa creating a condition known as split-horizon.
Info
On Subinterfaces Faxback Doc #subifs |
Info On IP
Unnumbered Faxback Doc #ip_unnum |
Get
The IOS Frame Relay Command Glossary. Faxback Doc #0550 Detailed descriptions of all IOS commands used in frame relay configurations. Also provides links to the IOS Command Reference if more information is required |
Get The IOS Command Line Interface
Tutorial Faxback Doc #ios_tutorial Instructions on configuring an IOS router using the command line interface |
Preconfiguration Checklist |
---|
Frame Relay Information The following info must be gathered from the frame relay provider
|
Network Information The following info must be gathered from the network administrator
|
Note: Commands followed by a <*> are on by default and do not have to be configured. The "!" marks that appear in the configuration are automatically entered by the router and function as line separators for easier reading.
Atlanta Router Configuration
In IOS "show running-config" format
version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Atlanta
!
enable secret cisco
!
ip subnet-zero
no ip domain-lookup
!
interface Ethernet0
ip address 10.1.1.1 255.0.0.0
!
interface Serial0
no ip address <*>
encapsulation frame-relay
frame-relay lmi-type ansi
!
interface Serial0.16 point-to-point
description Frame Relay to Boston
ip unnumbered Ethernet0
frame-relay interface-dlci 16 broadcast
!
interface Serial0.17 point-to-point
description Frame Relay to Chicago
ip unnumbered Ethernet0
frame-relay interface-dlci 17 broadcast
!
router rip
version 2
network 10.0.0.0
no auto-summary
!
ip http server
ip classless
!
line con 0
password console
login
line aux 0 <*>
line vty 0 4
password telnet
login <*>
!
end <*>
Boston Router Configuration
In IOS "show running-config" format
version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Boston
!
enable secret cisco
!
ip subnet-zero
no ip domain-lookup
!
interface Ethernet0
ip address 20.1.1.1 255.0.0.0
!
interface Serial0
no ip address <*>
encapsulation frame-relay
!
interface Serial0.16 point-to-point
description Frame Relay to Atlanta
ip unnumbered Ethernet0
frame-relay interface-dlci 16 broadcast
!
router rip
version 2
network 20.0.0.0
no auto-summary
!
ip http server
ip classless
!
line con 0
password console
login
line aux 0 <*>
line vty 0 4
password telnet
login <*>
!
end <*>
Chicago Router Configuration
In IOS "show running-config" format
version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Chicago
!
enable secret cisco
!
ip subnet-zero
no ip domain-lookup
!
interface Ethernet0
ip address 30.1.1.1 255.0.0.0
!
interface Serial0
no ip address <*>
encapsulation frame-relay
frame-relay lmi-type ansi
!
interface Serial0.16 point-to-point
description Frame Relay to Atlanta
ip unnumbered Ethernet0
frame-relay interface-dlci 16 broadcast
!
router rip
version 2
network 30.0.0.0
no auto-summary
!
ip http server
ip classless
!
line con 0
password console
login
line aux 0 <*>
line vty 0 4
password telnet
login <*>
!
end <*>
After You've Tried
You've tried the configuration and it doesn't work. Help is available!
Get IOS Router Frame Relay
Troubleshooting Assistance Faxback Doc #fr_ts |
All contents copyright © Cisco Systems, Inc. Important notices.