Hub And Spoke Frame Relay Sample Configuration Dynamic IP And IPX Routing |
Cisco ConfigMaker Windows 95/NT 4.0 configuration tool |
---|
The following is a sample configuration for a simple analog setup. Both MC3810s have 2 FXS ports with analog phones attached to the MC3810. The configurations for using the main serial interface and using a point-to-point sub-interface will be discussed.
Get
The IOS Frame Relay Command Glossary. Faxback Doc #0553 Detailed descriptions of all IOS commands used in frame relay configurations. Also provides links to the IOS Command Reference if more information is required |
Get The IOS Command Line Interface
Tutorial Faxback Doc #0563 Instructions on configuring an IOS router using the command line interface |
Preconfiguration Checklist |
---|
Frame Relay Information The following info must be gathered from the frame relay provider
|
Network Information The following info must be gathered from the network administrator
|
Note: Commands followed by a <*> are on by default and do not have to be configured. The "!" marks that appear in the configuration are automatically entered by the router and function as line separators for easier reading.
Remote#
Remote#
Remote#wr t
Building configuration...
Current configuration:
!
version 11.3
no service pad
no service password-encryption
!
hostname Remote
!
enable password voice
!
!
!
controller T1 0
framing esf
linecode b8zs
channel-group 1 timeslots 1-24 speed 64
!
interface Ethernet0
ip address 10.1.1.1 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface Serial2
ip address 10.1.2.2 255.255.255.0
encapsulation frame-relay
no fair-queue
frame-relay map ip 10.1.2.1 100 broadcast
frame-relay interface-dlci 100 voice-encap 1500
class sample
hold-queue 1024 out
!
router eigrp 100
network 10.0.0.0
ip classless
!
map-class frame-relay sample
no frame-relay adaptive-shaping
frame-relay cir 128000
!
line con 0
line aux 0
line vty 0 4
login
!
!
voice-port 1/1
!
voice-port 1/2
!
dial-peer voice 1 pots
destination-pattern 201
port 1/1
!
dial-peer voice 2 pots
destination-pattern 202
port 1/2
!
dial-peer voice 100 vofr
destination-pattern 1..
session target Serial2 100
!
end
Remote#
Host#
Host#wr t
Building configuration...
Current configuration:
!
version 11.3
no service pad
no service password-encryption
!
hostname Host
!
enable password voice
!
!
!
controller T1 0
framing esf
linecode b8zs
channel-group 1 timeslots 1-24 speed 64
!
interface Ethernet0
ip address 10.1.3.1 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface Serial2
ip address 10.1.2.1 255.255.255.0
encapsulation frame-relay
no fair-queue
frame-relay map ip 10.1.2.2 100 broadcast
frame-relay interface-dlci 100 voice-encap 1500
class sample
hold-queue 1024 out
!
router eigrp 100
network 10.0.0.0
!
ip classless
!
map-class frame-relay sample
no frame-relay adaptive-shaping
frame-relay cir 128000
!
line con 0
line aux 0
line vty 0 4
login
!
!
voice-port 1/1
shutdown
!
voice-port 1/2
!
dial-peer voice 2 pots
destination-pattern 102
port 1/2
!
dial-peer voice 200 vofr
destination-pattern 2..
session target Serial2 100
!
end
Host#
controller T1 0
framing esf
linecode b8zs
Extended Super Frame and Binary Eight Zero Substitution are the framing/linecoding that most T1s will use. You will have to ask your phone company what frame type and linecode your line is using.
channel-group 1 timeslots 1-24 speed 64
The channel-group is used to define which of the 24 possible DS0s the router will use. The possible values of the channel-group are 0-23 and it doesn't matter which number is used. If you don't define a channel-group no data or voice will be sent out the MFT. You may use any part of the 24 timeslots. Remember to include the speed 64 part of the command. The controller requires a full T1/E1 signal in order to be active.
It does support fragmented T1/E1 lines. The DS0s that are used when the MC3810 is attached to a fragmented T1/E1 are defined using the channel-group command. Examples for a 512K line:
Channel-group 20 timeslots 16-24 speed 64
Channel-group 10 timeslots 1-8 speed 64
The channel-group defines the DS0s that interface Serial 2 will use. The T1/E1 specific commands are put under the controller and the layer 2 and 3 commands are configured under the Serial 2 interface. Since the channel-group uses the Serial 2 interface it isn't possible to define more than one channel-group. Other channelized T1/E1 cards on different routers, such as the 3600 series, allow the configuration of multiple channel-groups. Therefore, it isn’t possible to configure the MC3810 for multiple point to point leased lines to multiple remote sites. The MC3810 doesn't have this feature and there aren't any plans at this time to add the ability to configure multiple channel-groups.
interface Serial2
ip address 10.1.1.2 255.255.255.0
encapsulation frame-relay
no fair-queue
This command is automatically added when you enter the voice-encap command. Voice packets always have priority over data packets so none of the more sophisticated queuing mechanisms can be used. The queuing is voice packets first and FIFO for all other packets.
frame-relay map ip 10.1.1.1 100 broadcast
frame-relay interface-dlci 100 voice-encap 1500
This is a major difference in the configuration of the MC3810. Usually when the frame-relay map command is used the interface-dlci command isn’t needed. The MC3810 uses this command to define the size of the data packets. Even though the command is "voice-encap", it is defining the size that the data packets will be fragmented into using the Frame Relay Forum’s specification number 12 for data fragmentation over Frame Relay. It is most commonly referred to as FRF.12. Other Cisco routers don’t support FRF.12 currently and will not be able to pass data with a MC3810 that is using this type of fragmentation. Compliance to FRF.12 will be added in the 12.x version of software for the other routers.
The voice-encap size is determined by the speed of the pipe that is being used. In this sample configuration the entire 24 channels of the T1 are being used so the size is 1500 bytes which is the largest packet size that an ethernet interface will send into the router. When the encap size is 1500, no fragmentation is being done by the MC3810. The fragmentation size is 80 bytes per 64K of bandwidth so a 256K pipe would have a voice-encap size of 320. The data is fragmented so a large data packet will not delay a voice packet when using smaller bandwidth pipes.
class sample
The class sample is the name of the frame relay map-class that is used to define traffic shaping. Traffic shaping must be defined when transporting voice over frame relay. If traffic shaping isn’t defined the router will send packets to the frame relay cloud at the clock speed of the line. If the traffic is sent at a higher rate than the CIR packets will be delayed and perhaps even dropped. While TCP/IP will resend data, delaying or dropping voice packets will effect the voice quality.
hold-queue 1024 out
The hold-queue size is increased to 1024 in order to allow more buffers for the fragmentation of data packets and holding them in the queue while voice packets are being sent out of the interface. The command is automatically added when the interface is configured for voice.
map-class frame-relay sample
The map-class frame-relay is where the traffic shaping parameters are configured. The name used, sample, was defined under the serial interface with the "class sample" command. Multiple map-classes may be configured and more than one interface-dlci can use the same map-class. If different DLCIs have a different CIR then multiple map-classes will be needed.
no frame-relay adaptive-shaping
The default when the map-class is created is to not do adaptive-shaping. If you want to turn it on the options are BECN and Foresight.
frame-relay cir 128000
The Committed Information Rate is set to 128K. The CIR is determined when the frame relay service is ordered. It is the amount of bandwidth that the frame relay provider guarantees.
<P>voice-port 1/1!
voice-port 1/2
These are the analog ports. Only 2 analog cards are in this MC3810. Commands specific to the port are entered under the voice-port.
dial-peer voice 1 pots
destination-pattern 201
port 1/1
The "dial-peer voice xxx pots" command is used to define a port’s phone number. The destination-pattern defines the phone number of a port. The interface used is defined with the "port 1/1" command.. For more information see the Dial-Peer Explanation.
dial-peer voice 100 vofr
destination-pattern 1..
session target Serial2 100
A dial-peer voice xxx vofr is used to determine which DLCI the voice traffic that matches the destination-pattern will use. The destination-pattern is the phone number(s) of the remote ports. A period is a wild card that matches any number. The matching pattern for destination-pattern 1.. is a one and any other 2 numbers. For more information see the Dial-Peer Explanation.
The "session target Serial2 100" command defines the interface and DLCI that the voice packets will be sent out. The voice traffic will be sent out serial 2 over DLCI 100.
The serial interface may also be configured using a point-to-point sub-interface.
interface Serial2
no ip address
encapsulation frame-relay
no fair-queue
hold-queue 1024 out
!
interface Serial2.1 point-to-point
ip address 11.1.1.2 255.255.255.0
frame-relay interface-dlci 16 voice-encap 320
class serial0
Just like configuring any other Cisco router, when a point-to-point sub-interface is used the frame relay map isn’t required. The data fragmentation size in this example if 320 bytes, which is the size used for a 256K line. The frame relay class that is used for traffic shaping is entered under each sub-interface.
In an environment where voice quality is very important or cost isn’t a limiting factor a DLCI may be used to only transport voice. In that situation, an address isn’t required for the sub-interface. Note that traffic shaping is still required to regulate the speed that the voice packets are sent into the frame relay cloud.
After You've Tried
You've tried the configuration and it doesn't work. Help is available!
Get IOS Router Frame Relay
Troubleshooting Assistance |
All contents copyright © Cisco Systems, Inc. Important notices.