Hub And Spoke Frame Relay Sample Configuration Bridging All Protocols |
Cisco ConfigMaker Windows 95/NT 4.0 configuration tool |
---|
This sample configuration bridges all protocols over a partially-meshed frame relay network using point-to-point subinterfaces. The IP addresses included in the example are not necessary, but are encouraged to allow remote administration through telnet.
Subinterfaces logically divide a single, physical interface into separate, virtual point-to-point interfaces. A single frame relay interface connecting to multiple destinations can now be treated as a collection of point-to-point network segments.
In general, it is good practice to use subinterfaces for partially-meshed frame relay networks. A frame relay network designed with subinterfaces scales much easier to future expansion. Without subinterfaces, Boston is unable to receive updates from Chicago and vice versa creating a condition known as split-horizon.
Info
On Subinterfaces Faxback Doc #subifs |
Get
The IOS Frame Relay Command Glossary. Faxback Doc #0550 Detailed descriptions of all IOS commands used in frame relay configurations. Also provides links to the IOS Command Reference if more information is required |
Get The IOS Command Line Interface
Tutorial Faxback Doc #ios_tutorial Instructions on configuring an IOS router using the command line interface |
Preconfiguration Checklist |
---|
Frame Relay Information The following info must be gathered from the frame relay provider
|
Network Information The following info must be gathered from the network administrator
|
Note: Commands followed by a <*> are on by default and do not have to be configured. The "!" marks that appear in the configuration are automatically entered by the router and function as line separators for easier reading.
Atlanta Router Configuration
In IOS "show running-config" format
version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Atlanta
!
enable secret cisco
!
ip subnet-zero
no ip routing
no ip domain-lookup
!
interface Ethernet0
ip address 10.1.1.1 255.0.0.0
bridge-group 1
!
interface Serial0
no ip address <*>
encapsulation frame-relay
frame-relay lmi-type ansi
!
interface Serial0.16 point-to-point
description Frame Relay to Boston
ip address 10.1.1.1 255.0.0.0
frame-relay interface-dlci 16 broadcast
bridge-group 1
!
interface Serial0.17 point-to-point
description Frame Relay to Chicago
ip address 10.1.1.1 255.0.0.0
frame-relay interface-dlci 17 broadcast
bridge-group 1
!
ip http server
!
bridge 1 protocol ieee
!
line con 0
password console
login
line aux 0 <*>
line vty 0 4
password telnet
login <*>
!
end <*>
Boston Router Configuration
In IOS "show running-config" format
version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Boston
!
enable secret cisco
!
ip subnet-zero
no ip routing
no ip domain-lookup
!
interface Ethernet0
ip address 10.2.2.2 255.0.0.0
bridge-group 1
!
interface Serial0
no ip address <*>
encapsulation frame-relay
!
interface Serial0.16 point-to-point
description Frame Relay to Atlanta
ip address 10.2.2.2 255.0.0.0
frame-relay interface-dlci 16 broadcast
bridge-group 1
!
ip http server
!
bridge 1 protocol ieee
!
line con 0
password console
login
line aux 0 <*>
line vty 0 4
password telnet
login <*>
!
end <*>
Chicago Router Configuration
In IOS "show running-config" format
version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Chicago
!
enable secret cisco
!
ip subnet-zero
no ip routing
no ip domain-lookup
!
interface Ethernet0
ip address 10.3.3.3 255.0.0.0
bridge-group 1
!
interface Serial0
no ip address <*>
encapsulation frame-relay
frame-relay lmi-type ansi
!
interface Serial0.16 point-to-point
description Frame Relay to Atlanta
ip address 10.3.3.3 255.0.0.0
frame-relay interface-dlci 16 broadcast
bridge-group 1
!
ip http server
!
bridge 1 protocol ieee
!
line con 0
password console
login
line aux 0 <*>
line vty 0 4
password telnet
login <*>
!
end <*>
After You've Tried
You've tried the configuration and it doesn't work. Help is available!
Get IOS Router Frame Relay
Troubleshooting Assistance Faxback Doc #fr_ts |
All contents copyright © Cisco Systems, Inc. Important notices.