Previous Table of Contents Next


Using EIGRP as the IGP

BGP-learned defaults are injected into EIGRP via redistribution. The 0/0 metric needs to be converted into an EIGRP-compatible metric by using the default-metric router command. RTA will inject its default with a high metric in such a way that the internal router (RTG) always gets a lower metric via RTF.

RTA configuration:

    router eigrp 1
     redistribute bgp 3 route-map DEFAULT_ONLY
     passive-interface Serial0
     network 172.16.0.0
     default-metric 5 100 250 100 1500

    router bgp 3
     no synchronization
     network 172.16.70.0 mask 255.255.255.0
     network 172.16.220.0 mask 255.255.255.0
     neighbor 172.16.20.1 remote-as 1
     neighbor 172.16.20.1 filter-list 10 out
     neighbor 172.16.50.1 remote-as 3
     neighbor 172.16.50.1 route-map setlocalpref in
     no auto-summary

    ip as-path access-list 10 permit ^$
     access-list 5 permit 0.0.0.0

     route-map setlocalpref permit 10
      set local-preference 300

     route-map DEFAULT_ONLY permit 10
      match ip address 5

RTA uses a route map DEFAULT_ONLY to match on the default route 0/0. Any other updates will be prevented from being redistributed into EIGRP. RTA also sets the metric by using the default-metric router command.

In the same manner, RTF is redistributing only the 0/0 into EIGRP using the route map DEFAULT_ONLY. RTF uses the default-metric 1000 100 250 100 1500 statement to set its default metric to an EIGRP-compatible metric. Note the bandwidth portion (1000) of the default-metric statement in RTF, which is much higher than the bandwidth (5) in RTA. This makes the metric from RTF much lower than the one from RTA.

RTF configuration:

    router eigrp 1
     redistribute bgp 3 route-map DEFAULT_ONLY
     network 172.16.0.0
     default-metric 1000 100 250 100 1500

    router bgp 3
     no synchronization
     network 172.16.50.0 mask 255.255.255.0
     neighbor 172.16.70.1 remote-as 3
     neighbor 172.16.70.1 next-hop-self
     neighbor 192.68.5.2 remote-as 2
     neighbor 192.68.5.2 filter-list 10 out
     no auto-summary

     ip as-path access-list 10 permit ^$

     access-list 5 permit 0.0.0.0

     route-map DEFAULT_ONLY permit 10

     match ip address 5

RTG is running EIGRP only and is following the default for all routes outside AS3.

RTG configuration:

    router eigrp 1
     network 172.16.0.0

The following is the IP routing table of RTG. Note that RTG follows the default toward RTF.

    RTG#sh ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP,
    M - mobile, B - BGP
      D - EIGRP, EX - EIGRP external, O - OSPF,
      IA - OSPF inter area
      N1 - OSPF NSSA external type 1,
      N2 - OSPF NSSA external type 2
      E1 - OSPF external type 1, E2 - OSPF external type 2,
      E - EGP
     i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
      * - candidate default U - per-user static route, o - ODR

    Gateway of last resort is 172.16.50.1 to network 0.0.0.0

      172.16.0.0/16 is subnetted, 4 subnets
    D  172.16.220.0/24 [90/2195456] via 172.16.70.1, 00:12:17, Serial0
    C  172.16.50.0/24 is directly connected, Serial1
    D  172.16.20.0/24 [90/2681856] via 172.16.70.1, 00:12:17, Serial0
    C  172.16.70.0/24 is directly connected, Serial0
    D*EX 0.0.0.0/0 [170/3097600] via 172.16.50.1, 00:07:40, Serial1

Using IGRP as IGP

IGRP does not understand the 0.0.0.0 default. To set a default inside IGRP, the ip default-network global command needs to be set on RTA and RTF. The default network used needs to be redistributed into IGRP to set the default on the internal routers. A default-metric needs to be set for successful redistribution.

RTA is setting network 192.68.6.0/24 (or any other classfull network learned via BGP) to be the default network. RTA will redistribute that network only into IGRP.

RTA configuration:

    router igrp 1
     passive-interface Serial0
     redistribute bgp 3 route-map DEFAULT_ONLY
     network 172.16.0.0
     default-metric 5 100 250 100 1500

    router bgp 3
     no synchronization
     network 172.16.70.0 mask 255.255.255.0
     network 172.16.220.0 mask 255.255.255.0
     neighbor 172.16.20.1 remote-as 1
     neighbor 172.16.20.1 filter-list 10 out
     neighbor 172.16.50.1 remote-as 3
     neighbor 172.16.50.1 route-map setlocalpref in
     no auto-summary

    ip default-network 192.68.6.0
    ip as-path access-list 10 permit ^$

    access-list 5 permit 192.68.6.0 0.0.0.255

    route-map setlocalpref permit 10
    set local-preference 300

    route-map DEFAULT_ONLY permit 10
     match ip address 5

RTF is also setting its default, to 192.68.6.0/24, and redistributing the default, with a better metric, into IGRP.

RTF configuration:

    router igrp 1
     redistribute bgp 3 route-map DEFAULT_ONLY
     network 172.16.0.0
     default-metric 1000 100 250 100 1500

    router bgp 3
     no synchronization
     network 172.16.50.0 mask 255.255.255.0
     neighbor 172.16.70.1 remote-as 3
     neighbor 172.16.70.1 next-hop-self
     neighbor 192.68.5.2 remote-as 2
     neighbor 192.68.5.2 filter-list 10 out
     no auto-summary

    ip default-network 192.68.6.0
    ip as-path access-list 10 permit ^$

    access-list 5 permit 192.68.6.0 0.0.0.255

    route-map DEFAULT_ONLY permit 10
     match ip address 5

RTG is running IGRP only and is following the default for all routes outside AS3.

RTG configuration:

    router igrp 1
     network 172.16.0.0

The following is the IP routing table of RTG. Note that RTG follows the default toward RTF.

    RTG#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP,
    M - mobile, B - BGP
      D - EIGRP, EX - EIGRP external, O - OSPF,
      IA - OSPF inter area
      N1 - OSPF NSSA external type 1,
      N2 - OSPF NSSA external type 2
      E1 - OSPF external type 1, E2 - OSPF external type 2,
      E - EGP
      i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
      * - candidate default U - per-user static route, o - ODR

    Gateway of last resort is 172.16.50.1 to network 192.68.6.0

    I* 192.68.6.0/24 [100/8576] via 172.16.50.1, 00:00:32, Serial1
    172.16.0.0/16 is subnetted, 4 subnets
    I 172.16.220.0/24 [100/8576] via 172.16.70.1, 00:00:32, Serial0
    C  172.16.50.0/24 is directly connected, Serial1
    I  172.16.20.0/24 [100/10476] via 172.16.70.1, 00:00:32, Serial0
    C  172.16.70.0/24 is directly connected, Serial0


Previous Table of Contents Next