Leased Line Sample Configuration
Routing IPX; Bridging All Other Protocols
Cisco ConfigMaker
Windows 95/NT 4.0 configuration tool

Note: The following configuration is for IPX only. It is a good idea to consider adding TCP/IP to the routers as well as IPX. Even though your network demands are strictly IPX, having TCP/IP on the routers will allow easier management and configuration through a remote telnet session.

This sample configuration routes IPX and bridges all other protocols between two Cisco routers over a synchronous serial line. IPX RIP/SAP dynamically resolves IPX routes and services. The IP addresses included in the example is strictly for remote management via telnet. Notice that both routers are on the same IP network number since IP is bridged.

The default encapsulation type used on leased lines between two Cisco routers is HDLC. However, when connecting to a non-Cisco router, PPP encapsulation must be used for third party compatability. This example also discusses how PPP encapsulation can be easily substituted in place of HDLC.


Before you begin

Detailed IOS Command DescriptionsGet The IOS Leased Line Command Glossary.
Faxback Doc #0553
Detailed descriptions of all IOS commands used in frame relay configurations. Also provides links to the IOS Command Reference if more information is required
IOS Command Line TutorialGet The IOS Command Line Interface Tutorial
Faxback Doc #ios_tutorial
Instructions on configuring an IOS router using the command line interface
Preconfiguration Checklist
Leased Line Information
The following info must be gathered from the circuit provider
  1. DSU/CSU Information
    The circuit provider must provide clocking, data framing, and line encoding information to configure DSU/CSU successfully.
Network Information
The following info must be gathered from the network administrator
  1. IP Address Information
    An IP network design must be created if router management via telnet is desired

  2. IPX Address Information
    An IPX network design must be created. Each network segment requires a unique IPX network number.

Note: Commands followed by a <*> are on by default and do not have to be configured. The "!" marks that appear in the configuration are automatically entered by the router and function as line separators for easier reading.


Atlanta Router Configuration
In IOS "show running-config" format

version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Atlanta
!
enable secret cisco
!
ip subnet-zero
no ip routing
no ip domain-lookup
ipx routing 0000.0caa.1111
!
interface Ethernet0
 ip address 10.1.1.1 255.0.0.0
 ipx network 100 encapsulation SAP
 ipx network 101 encapsulation NOVELL-ETHER secondary
 bridge-group 1
!
interface Serial0
 description Leased Line to Boston
 ip address 10.1.1.1 255.0.0.0
 ** add 'encapsulation ppp' here if communicating with third party routers **
 ipx network AAAA
 bridge-group 1
!
ip http server
!
bridge 1 protocol ieee
!
line con 0
 password console
 login
line aux 0 <*>
line vty 0 4
 password telnet
 login <*>
!
end <*>


Boston Router Configuration
In IOS "show running-config" format

version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Boston
!
enable secret cisco
!
ip subnet-zero
no ip routing
no ip domain-lookup
ipx routing 0000.0cbb.2222
!
interface Ethernet0
 ip address 10.2.2.2 255.0.0.0
 ipx network 200
 bridge-group 1
!
interface Serial0
 description Leased Line to Atlanta
 ip address 10.2.2.2 255.0.0.0
 ipx network AAAA
 bridge-group 1
!
ip http server
!
bridge 1 protocol ieee
!
line con 0
 password console
 login
line aux 0 <*>
line vty 0 4
 password telnet
 login <*>
!
end <*>


After You've Tried

You've tried the configuration and it doesn't work. Help is available!

IOS Router Leased Line Troubleshooting GuideGet IOS Router Leased Line Troubleshooting Assistance
Faxback Doc #ll_ts
 

All contents copyright © Cisco Systems, Inc. Important notices.