Leased Line Sample Configuration
Static IP And IPX Routing
Cisco ConfigMaker
Windows 95/NT 4.0 configuration tool

This sample configuration routes both TCP/IP and IPX between two Cisco routers over a synchronous serial line. Static IP routes and static IPX routes and services must be manually created on every router for each desired destination. For smaller networks, static routing may suffice. However, for larger networks, manually maintaining static routing tables on every router can be an undesirable administrative chore.

Dynamic IP And IPX Routing ConfigurationGet A Dynamically Routed IP and IPX Configuration (recommended)
Faxback Doc #0533

The default encapsulation type used on leased lines between two Cisco routers is HDLC. However, when connecting to a non-Cisco router, PPP encapsulation must be used for third party compatability. This example also discusses how PPP encapsulation can be easily substituted in place of HDLC.

IP Unnumbered TutorialInfo On IP Unnumbered
Faxback Doc #ip_unnum
 

Before you begin

Detailed IOS Command DescriptionsGet The IOS Leased Line Command Glossary.
Faxback Doc #0553
Detailed descriptions of all IOS commands used in frame relay configurations. Also provides links to the IOS Command Reference if more information is required
IOS Command Line TutorialGet The IOS Command Line Interface Tutorial
Faxback Doc #ios_tutorial
Instructions on configuring an IOS router using the command line interface
Preconfiguration Checklist
Leased Line Information
The following info must be gathered from the circuit provider
  1. DSU/CSU Information
    The circuit provider must provide clocking, data framing, and line encoding information to configure DSU/CSU successfully.
Network Information
The following info must be gathered from the network administrator
  1. IP Address Information
    An IP network design must be created. Separate IP network subnets are required at each site.

  2. IPX Address Information
    An IPX network design must be created. Each network segment requires a unique IPX network number.

Note: Commands followed by a <*> are on by default and do not have to be configured. The "!" marks that appear in the configuration are automatically entered by the router and function as line separators for easier reading.


Atlanta Router Configuration
In IOS "show running-config" format

version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Atlanta
!
enable secret cisco
!
ip subnet-zero
no ip domain-lookup
ipx routing 0000.0caa.1111
!
interface Ethernet0
 ip address 10.1.1.1 255.0.0.0
 ipx network 100 encapsulation SAP
 ipx network 101 encapsulation NOVELL-ETHER secondary
!
interface Serial0
 description Leased Line to Boston
 ip unnumbered Ethernet0
 ** add 'encapsulation ppp' here if communicating with third party routers **
 ipx network AAAA
 ipx sap-interval 0
!
ip http server
ip classless
ip route 20.0.0.0 255.0.0.0 Serial0
!
ipx route 200 AAAA.0000.0cbb.2222
ipx route 2000 AAAA.0000.0cbb.2222
!
ipx router rip
 no network AAAA
!
ipx sap 4 BostonFS 2000.0000.0000.0001 451 2
!
line con 0
 password console
 login
line aux 0 <*>
line vty 0 4
 password telnet
 login <*>
!
end <*>


Boston Router Configuration
In IOS "show running-config" format

version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Boston
!
enable secret cisco
!
ip subnet-zero
no ip domain-lookup
ipx routing 0000.0cbb.2222
!
interface Ethernet0
 ip address 20.1.1.1 255.0.0.0
 ipx network 200
!
interface Serial0
 description Leased Line to Atlanta
 ip unnumbered Ethernet0
 ipx network AAAA
 ipx sap-interval 0
!
ip http server
ip classless
ip route 10.0.0.0 255.0.0.0 Serial0
!
ipx route 100 AAAA.0000.0caa.1111
ipx route 1000 AAAA.0000.0caa.1111
!
ipx router rip
 no network AAAA
!
ipx sap 4 AtlantaFS 1000.0000.0000.0001 451 2
!
line con 0
 password console
 login
line aux 0 <*>
line vty 0 4
 password telnet
 login <*>
!
end <*>


After You've Tried

You've tried the configuration and it doesn't work. Help is available!

IOS Router Leased Line Troubleshooting GuideGet IOS Router Leased Line Troubleshooting Assistance
Faxback Doc #ll_ts
 

All contents copyright © Cisco Systems, Inc. Important notices.