Leased Line Sample Configuration Static IP Routing |
Cisco ConfigMaker Windows 95/NT 4.0 configuration tool |
---|
This sample configuration routes IP between two Cisco routers over a synchronous serial line. Static IP routes must be manually created on every router for each desired destination. For smaller networks, static routing may suffice. However, for larger networks, manually maintaining static routing tables on every router can be an undesirable administrative chore.
Get A Dynamically Routed IP Configuration (recommended)
Faxback Doc #0531
The default encapsulation type used on leased lines between two Cisco routers is HDLC. However, when connecting to a non-Cisco router, PPP encapsulation must be used for third party compatability. This example also discusses how PPP encapsulation can be easily substituted in place of HDLC.
Info On IP
Unnumbered Faxback Doc #ip_unnum |
Get
The IOS Leased Line Command Glossary. Faxback Doc #0553 Detailed descriptions of all IOS commands used in frame relay configurations. Also provides links to the IOS Command Reference if more information is required |
Get The IOS Command Line Interface
Tutorial Faxback Doc #ios_tutorial Instructions on configuring an IOS router using the command line interface |
Preconfiguration Checklist |
---|
Leased Line Information The following info must be gathered from the circuit provider
|
Network Information The following info must be gathered from the network administrator
|
Note: Commands followed by a <*> are on by default and do not have to be configured. The "!" marks that appear in the configuration are automatically entered by the router and function as line separators for easier reading.
Atlanta Router Configuration
In IOS "show running-config" format
version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Atlanta
!
enable secret cisco
!
ip subnet-zero
no ip domain-lookup
!
interface Ethernet0
ip address 10.1.1.1 255.0.0.0
!
interface Serial0
description Leased Line to Boston
ip unnumbered Ethernet0
add 'encapsulation ppp' here if communicating with third party routers
!
ip http server
ip classless
ip route 20.0.0.0 255.0.0.0 Serial0
!
line con 0
password console
login
line aux 0 <*>
line vty 0 4
password telnet
login <*>
!
end <*>
Boston Router Configuration
In IOS "show running-config" format
version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Boston
!
enable secret cisco
!
ip subnet-zero
no ip domain-lookup
!
interface Ethernet0
ip address 20.1.1.1 255.0.0.0
!
interface Serial0
description Leased Line to Atlanta
ip unnumbered Ethernet0
!
ip http server
ip classless
ip route 10.0.0.0 255.0.0.0 Serial0
!
line con 0
password console
login
line aux 0 <*>
line vty 0 4
password telnet
login <*>
!
end <*>
After You've Tried
You've tried the configuration and it doesn't work. Help is available!
Get IOS Router Leased Line
Troubleshooting Assistance Faxback Doc #ll_ts |
All contents copyright © Cisco Systems, Inc. Important notices.