Leased Line Sample Configuration
Bridging All Protocols
Cisco ConfigMaker
Windows 95/NT 4.0 configuration tool

This sample configuration bridges all protocols between two Cisco routers over a synchronous serial line. When a network is bridged instead of routed, both sites are part of the same logical network. To illustrate this, the above diagram includes some IP and IPX network numbers. However, the information is not necessary when configuring the router as a bridge.

The default encapsulation type used on leased lines between two Cisco routers is HDLC. However, when connecting to a non-Cisco router, PPP encapsulation must be used for third party compatability. This example also discusses how PPP encapsulation can be easily substituted in place of HDLC.

Note: The IP addresses included in this example are not necessary, but is encouraged to allow remote administration through telnet.


Before you begin

Detailed IOS Command DescriptionsGet The IOS Leased Line Command Glossary.
Faxback Doc #0553
Detailed descriptions of all IOS commands used in frame relay configurations. Also provides links to the IOS Command Reference if more information is required
IOS Command Line TutorialGet The IOS Command Line Interface Tutorial
Faxback Doc #ios_tutorial
Instructions on configuring an IOS router using the command line interface
Preconfiguration Checklist
Leased Line Information
The following info must be gathered from the circuit provider
  1. DSU/CSU Information
    The circuit provider must provide clocking, data framing, and line encoding information to configure DSU/CSU successfully.
Network Information
The following info must be gathered from the network administrator
  1. LAN Protocol Information
    Verify that the LANs at both locations are designed with bridging instead of routing in mind.

Note: Commands followed by a <*> are on by default and do not have to be configured. The "!" marks that appear in the configuration are automatically entered by the router and function as line separators for easier reading.


Atlanta Router Configuration
In IOS "show running-config" format

version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Atlanta
!
enable secret cisco
!
ip subnet-zero
no ip routing
no ip domain-lookup
!
interface Ethernet0
 ip address 10.1.1.1 255.0.0.0
 bridge-group 1
!
interface Serial0
 description Leased Line to Boston
 ip address 10.1.1.1 255.0.0.0
 ** add 'encapsulation ppp' to communicate with third party routers **
 bridge-group 1
!
ip http server
!
bridge 1 protocol ieee
!
line con 0
 password console
 login
line aux 0 <*>
line vty 0 4
 password telnet
 login <*>
!
end <*>


Boston Router Configuration
In IOS "show running-config" format

version 11.2 <*>
service udp-small-servers <*>
service tcp-small-servers <*>
!
hostname Boston
!
enable secret cisco
!
ip subnet-zero
no ip routing
no ip domain-lookup
!
interface Ethernet0
 ip address 10.2.2.2 255.0.0.0
 bridge-group 1
!
interface Serial0
 description Leased Line to Boston
 ip address 10.2.2.2 255.0.0.0
 bridge-group 1
!
ip http server
!
bridge 1 protocol ieee
!
line con 0
 password console
 login
line aux 0 <*>
line vty 0 4
 password telnet
 login <*>
!
end <*>


After You've Tried

You've tried the configuration and it doesn't work. Help is available!

IOS Router Leased Line Troubleshooting GuideGet IOS Router Leased Line Troubleshooting Assistance
Faxback Doc #ll_ts
 

All contents copyright © Cisco Systems, Inc. Important notices.